[SOLVED]Blank page on portal.php

Current Version: 2.0.2
Released: 2013-10-27
Forum rules
Before creating a new support thread, please take a look at the board3 Portal FAQ and use the search!
Many questions have already been answered.
User avatar

Topic author
pokyto
Translator
Translator
Posts: 20
Joined: 1. August 2011 11:52
phpBB.com User: pokyto
Location: Nancy / FRANCE

[SOLVED]Blank page on portal.php

Post by pokyto »

Hi!

after the install of board3_portal_2_0_0b1 i get nothing on my root/portal.php !!
just a blank page with the word "bloc" in the top left corner

i have the same error in the acp when i clic on the "Portal Modules" link

my local site runs on wamp server 2.0 (php 5.3.0)

see what i get on this image => http://hebergeurimage.free.fr/nothing_o ... 182335.jpg

any idea ??
Last edited by pokyto on 5. August 2011 17:03, edited 1 time in total.
User avatar

archivar
Portal Professional
Portal Professional
Posts: 1885
Joined: 19. April 2009 21:34
phpBB.de User: archivar
phpBB.com User: archivar
Location: Deutschland

Re: Blank page on portal.php

Post by archivar »

A link to the Board would be helpful.
V.G. archivar
sorry for my bad english
User avatar

Topic author
pokyto
Translator
Translator
Posts: 20
Joined: 1. August 2011 11:52
phpBB.com User: pokyto
Location: Nancy / FRANCE

Re: Blank page on portal.php

Post by pokyto »

archivar wrote:A link to the Board would be helpful.
yes i know but this is a work in progress site, and for now only in local ... my actual site runs online/local with board3_portal_1_0_6 perfectly !!

edit : well !! i give up! the more i search the less i understand where is the error!!
i'll wait for the release instead of trying with a beta
User avatar

Topic author
pokyto
Translator
Translator
Posts: 20
Joined: 1. August 2011 11:52
phpBB.com User: pokyto
Location: Nancy / FRANCE

Re: Blank page on portal.php

Post by pokyto »

Hi!!

I uploaded a fresh install of phpbb 3.0.9 + board3 2.0.0b1
i get the same error as previously, online and in local

you can see what i get on this test URL => http://essai.lestontonsfraggers.com
i can send you by MP login and password of the admin account ... i really don't understand what i'm doing wrong !!??

Thx !

Edit: i think i found the problem ... the error appears when i turn on the french language in my profil or/and in the general settings,
if i turn back the forum on english or german there is no error !
User avatar

archivar
Portal Professional
Portal Professional
Posts: 1885
Joined: 19. April 2009 21:34
phpBB.de User: archivar
phpBB.com User: archivar
Location: Deutschland

Re: Blank page on portal.php

Post by archivar »

Remove this code in all standard French language files *. php files on the final of the portal v. 2b1:
in last line:

Code: Select all

?>
Refresh your Styles:
"Administration Control Panel" (ACP) > "Styles" > "Templates" > each > "refresh"
"Administration Control Panel" (ACP) > "Styles" > "Themes" > each > "refresh"
"Administration Control Panel" (ACP) > "Styles" > "Imagesets" > each > "refresh"

Clear your cache in the "Administration Control Panel" (ACP) > "General" > "Purge the cache"
;)
V.G. archivar
sorry for my bad english
User avatar

Topic author
pokyto
Translator
Translator
Posts: 20
Joined: 1. August 2011 11:52
phpBB.com User: pokyto
Location: Nancy / FRANCE

Re: Blank page on portal.php

Post by pokyto »

nope! it doesn't change the problem, i always have a blank page on the portal if i set "french" as default language even after the changes

i also made the changes online if you want to check

i think i found an other mistake in the french transalation files in root\language\fr\mods\portal\portal_whois_online_module.php

there is a "bloc" just before "<?php" .. first line .... but with or without this word the error persists

Code: Select all

 bloc<?php
/**
*
* @package Board3 Portal v2 - Who is online
* @copyright (c) Board3 Group ( www.board3.de )
* @license http://opensource.org/licenses/gpl-license.php GNU Public License
* @translated by anywhere91 for zone-bf.com
*
*/

/**
* DO NOT CHANGE
User avatar

archivar
Portal Professional
Portal Professional
Posts: 1885
Joined: 19. April 2009 21:34
phpBB.de User: archivar
phpBB.com User: archivar
Location: Deutschland

Re: Blank page on portal.php

Post by archivar »

Please Turn the debug mode.
V.G. archivar
sorry for my bad english
User avatar

Topic author
pokyto
Translator
Translator
Posts: 20
Joined: 1. August 2011 11:52
phpBB.com User: pokyto
Location: Nancy / FRANCE

Re: Blank page on portal.php

Post by pokyto »

Done !

Code: Select all

Warning: Unexpected character in input: ''' (ASCII=39) state=1 in /home/hosted/usersSpace/17/ftp/lestontonsfraggers.com/essai/language/fr/mods/portal/portal_latest_members_module.php on line 42

Parse error: syntax error, unexpected T_STRING, expecting ')' in /home/hosted/usersSpace/17/ftp/lestontonsfraggers.com/essai/language/fr/mods/portal/portal_latest_members_module.php on line 42
line 42 of root/language/fr/mods/portal/portal_latest_members_module.php

Code: Select all

	'PORTAL_MAX_LAST_MEMBER_EXP'		=> '0 signifie infinis,
missing quotes before the semicolon at the end of the string !!

with this string

Code: Select all

	'PORTAL_MAX_LAST_MEMBER_EXP'		=> '0 signifie infinis',
that works !!

Thank you very much for your expertise and your patience !!

Return to “Board3 Portal 2.0.x - English Support”