Fehler bei update_106_to_200b1

Aktuelle Version: 2.0.2
Veröffentlicht: 27.10.2013
Forum rules
Vor dem erstellen neuer Supportanfragen bitte zuerst in die board3 Portal FAQ schauen und die Suche benutzen!
Viele Fragen sind bereits schon gestellt und beantwortet worden.
Bitte auch unsere Forumsregeln lesen und beachten!
User avatar
winnetou
Topic author
Active Member
Active Member
Posts: 44
Joined: 10. March 2010 21:48
phpBB.de User: winnetou
Location: Bremen

Fehler bei update_106_to_200b1

Post by winnetou » 28. July 2011 17:27

Hallo,
ich habe gerade das update gemacht. Dabei bekam ich diese Meldung:
Konvertiere von Board3 Portal 1.0.6 & füge Basismodule hinzu
SQL ERROR Table 'usr_web42_2.phpbb_portal_modules' doesn't exist
Wenn ich das Portal jetzt aufrufe kommt diese Fehlermeldung:
Allgemeiner Fehler
SQL ERROR [ mysqli ]

Table 'usr_web42_2.phpbb_portal_modules' doesn't exist [1146]

SQL

SELECT * FROM phpbb_portal_modules ORDER BY module_order ASC

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: portal/includes/functions.php
LINE: 82
CALL: dbal_mysqli->sql_query()

FILE: portal.php
LINE: 44
CALL: obtain_portal_modules()
Was muss ich denn jetzt machen? Bitte um Hilfe.
Link zur Seite: http://www.aquaristikfreunde-bremen.de/portal.php

Gruss
Jürgen

User avatar
Kirk
Portal Professional
Portal Professional
Posts: 1424
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: Fehler bei update_106_to_200b1

Post by Kirk » 28. July 2011 17:36

Hallo

Hast du auch die install/index.php aufgerufen?
Gruß Udo

User avatar
winnetou
Topic author
Active Member
Active Member
Posts: 44
Joined: 10. March 2010 21:48
phpBB.de User: winnetou
Location: Bremen

Re: Fehler bei update_106_to_200b1

Post by winnetou » 28. July 2011 17:39

Hallo,
ja im Acp wird die aktuelle Portal version angezeigt. Klicke ich unter Mods auf Portal Module kommt diese Fehlermeldung:

Code: Select all

Allgemeiner Fehler
SQL ERROR [ mysqli ]

Table 'usr_web42_2.phpbb_portal_modules' doesn't exist [1146]

SQL

SELECT * FROM phpbb_portal_modules ORDER BY module_order ASC

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: portal/includes/functions.php
LINE: 82
CALL: dbal_mysqli->sql_query()

FILE: includes/acp/acp_portal.php
LINE: 865
CALL: obtain_portal_modules()

FILE: includes/functions_module.php
LINE: 507
CALL: acp_portal->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()

User avatar
archivar
Portal Professional
Portal Professional
Posts: 1870
Joined: 19. April 2009 21:34
phpBB.de User: archivar
phpBB.com User: archivar
Location: Deutschland

Re: Fehler bei update_106_to_200b1

Post by archivar » 28. July 2011 18:15

Vor einem Update müssen alle Code anderer Mod´s, die für das alte Portal verbaut wurden, restlos entfernt werden.
Es geht um die Code, die auf das alte Portal zu greifen wollen aber das alte Portal nicht mehr finden.
Es kann sonst zu Fehlermeldungen kommen, die ein Außenstehender nicht immer klar deuten kann.
Wer soll wissen welche Adons. für das alte Portal verbaut wurden? :roll:
[Wichtig] Bitte zuerst lesen
Was wurde in Board3 Portal 2.0.0 verändert?
In Board3 Portal 2.0.0 wurde die komplette Basis umgeschreiben. Das heißt allerdings auch, dass die aktuellen Add-On Blöcke in B3P 2.0.x nicht mehr funktionieren werden.
V.G. archivar
sorry for my bad english

User avatar
winnetou
Topic author
Active Member
Active Member
Posts: 44
Joined: 10. March 2010 21:48
phpBB.de User: winnetou
Location: Bremen

Re: Fehler bei update_106_to_200b1

Post by winnetou » 28. July 2011 18:26

Hallo archivar,
ich verstehe nicht genau was Du meinst. Ich habe vor ein paar Tagen das Portal auf 1.0.6 aktualisiert, das ging. Dort habe ich nur ein eigenen Block eingerichtet. Wie muss ich denn jetzt vorgehen damit es läuft?

Gruss
Jürgen

User avatar
archivar
Portal Professional
Portal Professional
Posts: 1870
Joined: 19. April 2009 21:34
phpBB.de User: archivar
phpBB.com User: archivar
Location: Deutschland

Re: Fehler bei update_106_to_200b1

Post by archivar » 28. July 2011 18:31

Überprüfe in aller ruhe noch mal die geforderten Änderungen an den Dateien auf fehlerhaften Einbau.
Wenn Du mit einem Update nicht zurecht kommst, dann mach halt eine "Neuinstallation" und deinstalliere/baue vorher das alte Portal restlos aus.
V.G. archivar
sorry for my bad english

User avatar
winnetou
Topic author
Active Member
Active Member
Posts: 44
Joined: 10. March 2010 21:48
phpBB.de User: winnetou
Location: Bremen

Re: Fehler bei update_106_to_200b1

Post by winnetou » 28. July 2011 19:22

Hallo,
ich bin die anleitung mehrmals durchgegangen, daran lag es nicht. Nun habe ich erstmal alles rückgängig auf 1.0.6 gemacht. Wie bekomme ich denn das Portal komplett raus ohne andere Sachen zu zerstören? Um es dann neu zu installieren?

Gruss
Jürgen

User avatar
archivar
Portal Professional
Portal Professional
Posts: 1870
Joined: 19. April 2009 21:34
phpBB.de User: archivar
phpBB.com User: archivar
Location: Deutschland

Re: Fehler bei update_106_to_200b1

Post by archivar » 28. July 2011 20:52

So wie Du es vorwärts installiert hast machst Du das rückwärts.
V.G. archivar
sorry for my bad english

User avatar
winnetou
Topic author
Active Member
Active Member
Posts: 44
Joined: 10. March 2010 21:48
phpBB.de User: winnetou
Location: Bremen

Re: Fehler bei update_106_to_200b1

Post by winnetou » 28. July 2011 20:53

Hallo,
ich habe es hinbekommen,freu! Wie bekomme ich jetzt ein Galerie Block darein? Ich kann ja ein Modul hinzufügen als zip. Aber wo bekomme ich die her? Sorry, für die Anfänger fragen.

Gruss
Jürgen

User avatar
archivar
Portal Professional
Portal Professional
Posts: 1870
Joined: 19. April 2009 21:34
phpBB.de User: archivar
phpBB.com User: archivar
Location: Deutschland

Re: Fehler bei update_106_to_200b1

Post by archivar » 28. July 2011 20:57

winnetou wrote:Hallo,
ich habe es hinbekommen,freu! Wie bekomme ich jetzt ein Galerie Block darein? Ich kann ja ein Modul hinzufügen als zip. Aber wo bekomme ich die her? Sorry, für die Anfänger fragen.

Gruss
Jürgen
Und was ist das hier? viewforum.php?f=54
Schau auch mal hier hin: viewtopic.php?f=23&t=4770
Benutze bitte auch mal die "SUCHE", denn vieles wurde schon geschrieben.
V.G. archivar
sorry for my bad english

User avatar
winnetou
Topic author
Active Member
Active Member
Posts: 44
Joined: 10. March 2010 21:48
phpBB.de User: winnetou
Location: Bremen

Re: Fehler bei update_106_to_200b1

Post by winnetou » 31. July 2011 20:07

Hallo,
wenn ich im Adminbereich den Cache leere und dann zurück ist Forum will kommt diese Fehlermeldung:

Code: Select all

Allgemeiner Fehler
SQL ERROR [ mysqli ]

Table 'usr_web42_2.PORTAL_CONFIG_TABLE' doesn't exist [1146]

SQL

SELECT config_name, config_value FROM PORTAL_CONFIG_TABLE

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: portal/includes/functions.php
LINE: 26
CALL: dbal_mysqli->sql_query()

FILE: index.php
LINE: 45
CALL: obtain_portal_config()
Klicke ich dann auf aktualisieren komme ich ins Forum. Das ist immer nur nach dem leeren vom Cache. Was hat diese Fehlermeldung zu bedeuten?

Gruss
Jürgen

User avatar
archivar
Portal Professional
Portal Professional
Posts: 1870
Joined: 19. April 2009 21:34
phpBB.de User: archivar
phpBB.com User: archivar
Location: Deutschland

Re: Fehler bei update_106_to_200b1

Post by archivar » 31. July 2011 20:30

Ich bin mir fast sicher, dass dieser Beitrag auf dein Problem zutrifft:
viewtopic.php?f=48&t=4789#p28037
Denn ich hatte ähnliche Fehler-Meldungen nach dem Update. ;)
V.G. archivar
sorry for my bad english

User avatar
winnetou
Topic author
Active Member
Active Member
Posts: 44
Joined: 10. March 2010 21:48
phpBB.de User: winnetou
Location: Bremen

Re: Fehler bei update_106_to_200b1

Post by winnetou » 31. July 2011 20:52

Hallo,
ich hatte alles zurück installiert auf 1.0.6 und danach genau nach updateinstall.xml von board3_portal_2_0_0b1
erneuert.
Wo ist denn jetzt der Fehler dabei?
In der Fehlermeldung steht auch was von includes/constants.php, dort ist aber laut anleitung kein code mehr drin.

Gruss
Jürgen

User avatar
Marc
Dev
Dev
Posts: 2487
Joined: 17. July 2008 21:08
phpBB.de User: marc1706
phpBB.com User: Marc
Location: Clausthal-Zellerfeld / München

Re: Fehler bei update_106_to_200b1

Post by Marc » 31. July 2011 21:58

Könntest du den Inhalt deiner index.php mal hier posten?

User avatar
winnetou
Topic author
Active Member
Active Member
Posts: 44
Joined: 10. March 2010 21:48
phpBB.de User: winnetou
Location: Bremen

Re: Fehler bei update_106_to_200b1

Post by winnetou » 31. July 2011 22:08

Hallo Marc,

hier die index.php:

Code: Select all

<?php
/**
*
* @package phpBB3
* @version $Id: index.php 9614 2009-06-18 11:04:54Z nickvergessen $
* @copyright (c) 2005 phpBB Group
* @license http://opensource.org/licenses/gpl-license.php GNU Public License
*
*/

/**
*/

/**
* @ignore
*/
define('IN_PHPBB', true);
$phpbb_root_path = (defined('PHPBB_ROOT_PATH')) ? PHPBB_ROOT_PATH : './';
$phpEx = substr(strrchr(__FILE__, '.'), 1);
include($phpbb_root_path . 'common.' . $phpEx);
include($phpbb_root_path . 'includes/functions_display.' . $phpEx);

// Start session management
$user->session_begin();
$auth->acl($user->data);
$user->setup('viewforum');
if (!function_exists('as_display'))
{
	include($phpbb_root_path . 'includes/functions_shoutbox.' . $phpEx);
}
as_display();
/**
* Recent images & comments and random images
*
* borrowed from phpBB Gallery
* @author: nickvergessen
* @function: recent_gallery_images
*/

$gallery_root_path = GALLERY_ROOT_PATH;

if (!function_exists('obtain_portal_config'))
{
	include($phpbb_root_path . 'portal/includes/functions.' . $phpEx);
	$portal_config = obtain_portal_config();
}
if (!function_exists('load_gallery_config'))
{
	$recent_image_addon = true;
	include($phpbb_root_path . $gallery_root_path . 'includes/common.' . $phpEx);
	include($phpbb_root_path . $gallery_root_path . 'includes/permissions.' . $phpEx);
}

include($phpbb_root_path . $gallery_root_path . 'includes/functions_recent.' . $phpEx);
$ints = array(
	'rows'		=> $portal_config['portal_pg_index_rows'],
	'columns'	=> $portal_config['portal_pg_index_columns'],
	'comments'	=> $portal_config['portal_pg_index_crows'],
	'contests'	=> $portal_config['portal_pg_index_contests'],
);
/**
* int		array	including all relevent numbers for rows, columns and stuff like that,
* display	int		sum of the options which should be displayed, see gallery/includes/constants.php "// Display-options for RRC-Feature" for values
* modes		int		sum of the modes which should be displayed, see gallery/includes/constants.php "// Mode-options for RRC-Feature" for values
* collapse	bool	collapse comments
* include_pgalleries	bool	include personal albums
* mode_id	string	'user' or 'album' to only display images of a certain user or album
* id		int		user_id for user profile or album_id for view of recent and random images
*/
if ($portal_config['portal_pg_index_mode'] != '!all')
{
	recent_gallery_images($ints, $portal_config['portal_pg_index_display'], $portal_config['portal_pg_index_mode'], $portal_config['portal_pg_index_comments'], $portal_config['portal_pg_index_pgalleries']);
}

display_forums('', $config['load_moderators']);

// Set some stats, get posts count from forums data if we... hum... retrieve all forums data
$total_posts	= $config['num_posts'];
$total_topics	= $config['num_topics'];
$total_users	= $config['num_users'];
$total_images	= $config['num_images'];
$user->add_lang('mods/info_acp_gallery');
$l_total_image_s = ($total_images == 0) ? 'TOTAL_IMAGES_ZERO' : 'TOTAL_IMAGES_OTHER';
$l_total_user_s = ($total_users == 0) ? 'TOTAL_USERS_ZERO' : 'TOTAL_USERS_OTHER';
$l_total_post_s = ($total_posts == 0) ? 'TOTAL_POSTS_ZERO' : 'TOTAL_POSTS_OTHER';
$l_total_topic_s = ($total_topics == 0) ? 'TOTAL_TOPICS_ZERO' : 'TOTAL_TOPICS_OTHER';

// Grab group details for legend display
if ($auth->acl_gets('a_group', 'a_groupadd', 'a_groupdel'))
{
	$sql = 'SELECT group_id, group_name, group_colour, group_type
		FROM ' . GROUPS_TABLE . '
		WHERE group_legend = 1
		ORDER BY group_name ASC';
}
else
{
	$sql = 'SELECT g.group_id, g.group_name, g.group_colour, g.group_type
		FROM ' . GROUPS_TABLE . ' g
		LEFT JOIN ' . USER_GROUP_TABLE . ' ug
			ON (
				g.group_id = ug.group_id
				AND ug.user_id = ' . $user->data['user_id'] . '
				AND ug.user_pending = 0
			)
		WHERE g.group_legend = 1
			AND (g.group_type <> ' . GROUP_HIDDEN . ' OR ug.user_id = ' . $user->data['user_id'] . ')
		ORDER BY g.group_name ASC';
}
$result = $db->sql_query($sql);

$legend = array();
while ($row = $db->sql_fetchrow($result))
{
	$colour_text = ($row['group_colour']) ? ' style="color:#' . $row['group_colour'] . '"' : '';
	$group_name = ($row['group_type'] == GROUP_SPECIAL) ? $user->lang['G_' . $row['group_name']] : $row['group_name'];

	if ($row['group_name'] == 'BOTS' || ($user->data['user_id'] != ANONYMOUS && !$auth->acl_get('u_viewprofile')))
	{
		$legend[] = '<span' . $colour_text . '>' . $group_name . '</span>';
	}
	else
	{
		$legend[] = '<a' . $colour_text . ' href="' . append_sid("{$phpbb_root_path}memberlist.$phpEx", 'mode=group&g=' . $row['group_id']) . '">' . $group_name . '</a>';
	}
}
$db->sql_freeresult($result);

$legend = implode(', ', $legend);

// Generate birthday list if required ...
$birthday_list = '';
if ($config['load_birthdays'] && $config['allow_birthdays'])
{
	$now = getdate(time() + $user->timezone + $user->dst - date('Z'));
	$sql = 'SELECT u.user_id, u.username, u.user_colour, u.user_birthday
		FROM ' . USERS_TABLE . ' u
		LEFT JOIN ' . BANLIST_TABLE . " b ON (u.user_id = b.ban_userid)
		WHERE (b.ban_id IS NULL
			OR b.ban_exclude = 1)
			AND u.user_birthday LIKE '" . $db->sql_escape(sprintf('%2d-%2d-', $now['mday'], $now['mon'])) . "%'
			AND u.user_type IN (" . USER_NORMAL . ', ' . USER_FOUNDER . ')';
	$result = $db->sql_query($sql);

	while ($row = $db->sql_fetchrow($result))
	{
		$birthday_list .= (($birthday_list != '') ? ', ' : '') . get_username_string('full', $row['user_id'], $row['username'], $row['user_colour']);

		if ($age = (int) substr($row['user_birthday'], -4))
		{
			$birthday_list .= ' (' . ($now['year'] - $age) . ')';
		}
	}
	$db->sql_freeresult($result);
}

if (!function_exists('display_who_was_here'))
{
	include($phpbb_root_path . 'includes/functions_wwh.' . $phpEx);
}
display_who_was_here();
// if automatic reminders is set, remind people. lets only run this once a day.
if (isset($config['user_reminder_enable']))
{
	if ( $config['user_reminder_enable'] == ENABLED )
	{
		$check_time = (int) gmdate('mdY',time() + (3600 * ($config['board_timezone'] + $config['board_dst'])));
	
		if ( $config['user_reminder_last_auto_run'] != $check_time)
		{
			if (!function_exists('send_user_reminders'))
			{
				include($phpbb_root_path . 'includes/functions_user_reminder.' . $phpEx);
			}
			
			send_user_reminders();
			
			if ($config['user_reminder_log_opt_users_react'])
			{
				add_log('admin', 'LOG_USER_REMINDER_AUTO_RUN');
			}
			
			set_config('user_reminder_last_auto_run', $check_time);
		}
	}
}
if (!class_exists('phpbb_mods_who_was_here'))
{
	include($phpbb_root_path . 'includes/mods/who_was_here.' . $phpEx);
	phpbb_mods_who_was_here::update_session();
}
phpbb_mods_who_was_here::display();
// Assign index specific vars
$template->assign_vars(array(
	'TOTAL_POSTS'	=> sprintf($user->lang[$l_total_post_s], $total_posts),
	'TOTAL_TOPICS'	=> sprintf($user->lang[$l_total_topic_s], $total_topics),
	'TOTAL_USERS'	=> sprintf($user->lang[$l_total_user_s], $total_users),
	'TOTAL_IMAGES'	=> ($config['gallery_total_images']) ? sprintf($user->lang[$l_total_image_s], $total_images) : '',
	'NEWEST_USER'	=> sprintf($user->lang['NEWEST_USER'], get_username_string('full', $config['newest_user_id'], $config['newest_username'], $config['newest_user_colour'])),

	'LEGEND'		=> $legend,
	'BIRTHDAY_LIST'	=> $birthday_list,

	'FORUM_IMG'				=> $user->img('forum_read', 'NO_UNREAD_POSTS'),
	'FORUM_UNREAD_IMG'			=> $user->img('forum_unread', 'UNREAD_POSTS'),
	'FORUM_LOCKED_IMG'		=> $user->img('forum_read_locked', 'NO_UNREAD_POSTS_LOCKED'),
	'FORUM_UNREAD_LOCKED_IMG'	=> $user->img('forum_unread_locked', 'UNREAD_POSTS_LOCKED'),

	'S_LOGIN_ACTION'			=> append_sid("{$phpbb_root_path}ucp.$phpEx", 'mode=login'),
	'S_DISPLAY_BIRTHDAY_LIST'	=> ($config['load_birthdays']) ? true : false,

	'U_MARK_FORUMS'		=> ($user->data['is_registered'] || $config['load_anon_lastread']) ? append_sid("{$phpbb_root_path}index.$phpEx", 'hash=' . generate_link_hash('global') . '&mark=forums') : '',
	'U_MCP'				=> ($auth->acl_get('m_') || $auth->acl_getf_global('m_')) ? append_sid("{$phpbb_root_path}mcp.$phpEx", 'i=main&mode=front', true, $user->session_id) : '')
);

if ($config['rt_index'])
{
	if (!function_exists('display_recent_topics'))
	{
		include($phpbb_root_path . 'includes/functions_recenttopics.' . $phpEx);
	}
	display_recent_topics($config['rt_number'], $config['rt_page_number'], $config['rt_anti_topics'], 'recent_topics', request_var('f', 0), true);
}

// Output page
page_header($user->lang['INDEX']);

$template->set_filenames(array(
	'body' => 'index_body.html')
);

page_footer();

?>
Gruss
Jürgen

Return to “Board3 Portal 2.0.x - Deutscher Support”

Who is online

Users browsing this forum: Bing [Bot], CommonCrawl [Bot] and 1 guest