Wrong link in portal Button

Current Version: 2.1.0
Released: 2015-10-26
Forum rules
Before creating a new support thread, please take a look at the board3 Portal FAQ and use the search!
Many questions have already been answered.
alexport
Topic author
Active Member
Active Member
Posts: 3
Joined: 13. June 2016 13:39

Wrong link in portal Button

Post by alexport » 13. June 2016 13:56

Your Portal Version: 2.1.0
Your phpBB Type: Standard phpBB3
MODs installed: No
Your knowledge: Basic Knowledge
Boardlink: http://paixnidi.org/mboard

What have you done before the problem was there?
Nothing

What have you already tryed to solve the problem?
Searched online

Description and Message
Hello. I installed the portal for an internal forum that just few users will use. It is located in a subfolder of the main site. My problem is that the "Portal" link redirects to a non existent page. mysite.com/subfolder/app.php/portal.
The weird thing is that the correct URL seems to be mysite.com/subfolder/app.php which works just fine. How can I change the portal's link from .../app.php/portal to plain .../app.php?

User avatar
Kirk
Portal Professional
Portal Professional
Posts: 1496
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: Wrong link in portal Button

Post by Kirk » 13. June 2016 18:11

Hi
You can set it so that appears yourdomain.com/portal
Go to ACP/server settings on Enable URL Rewriting: set to yes

alexport
Topic author
Active Member
Active Member
Posts: 3
Joined: 13. June 2016 13:39

Re: Wrong link in portal Button

Post by alexport » 13. June 2016 19:05

Kirk wrote:Hi
You can set it so that appears yourdomain.com/portal
Go to ACP/server settings on Enable URL Rewriting: set to yes
I enabled the option but still I get a 404 page.

Now it redirects to http://site/subfolder/portal which is not correct. The portal for some reason is on http://site/subfolder/app.php.

I just want to delete "/portal" from the link

alexport
Topic author
Active Member
Active Member
Posts: 3
Joined: 13. June 2016 13:39

Re: Wrong link in portal Button

Post by alexport » 13. June 2016 19:10

Kirk wrote:Hi
You can set it so that appears yourdomain.com/portal
Go to ACP/server settings on Enable URL Rewriting: set to yes
I think I didn't explain correctly. After the portal installation there is no "portal" subfolder in my FTP. I tried what you told me but now the link redirects to http://site/subfolder/portal which is not correct. Again the correct URL is http://site/subfolder/app.php which takes you to the portal by typing it.

Return to “Board3 Portal 2.1.x - English Support”