Portal on phpBB 3.3

Current Version: 2.1.0
Released: 2015-10-26
Forum rules
Before creating a new support thread, please take a look at the board3 Portal FAQ and use the search!
Many questions have already been answered.
User avatar

Topic author
Solidjeuh
Valued Contributor
Valued Contributor
Posts: 55
Joined: 26. January 2017 14:12
phpBB.com User: Froddelaar
Location: Aalst, Belgium

Portal on phpBB 3.3

Post by Solidjeuh » 31. October 2019 01:28

Hello,

I installed Board3 portal on phpBB 3.3, all works, but I get a warning in ACP

Code: Select all

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /var/www/vhosts/solidjeuh.be/httpdocs/ext/board3/portal/acp/portal_module.php on line 128

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /var/www/vhosts/solidjeuh.be/httpdocs/ext/board3/portal/acp/portal_module.php on line 448
Yeah I know, phpBB 3.3 is still not released, but i like to test things ;)
Register a free account & Play!!
~~~ https://www.solidjeuh.be ~~~
Have a secret? --> https://www.tellyoursecrets.eu

User avatar

Kirk
Portal Professional
Portal Professional
Posts: 1642
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: Portal on phpBB 3.3

Post by Kirk » 2. November 2019 15:34

Hi
Open: root/ext/board3/portal/acp/portal_module.php
Find on line 128: continue;
Replace with: break;

Find on line 448: continue;
Replace with: break;

User avatar

Topic author
Solidjeuh
Valued Contributor
Valued Contributor
Posts: 55
Joined: 26. January 2017 14:12
phpBB.com User: Froddelaar
Location: Aalst, Belgium

Re: Portal on phpBB 3.3

Post by Solidjeuh » 2. November 2019 22:40

Great! Thank you
Register a free account & Play!!
~~~ https://www.solidjeuh.be ~~~
Have a secret? --> https://www.tellyoursecrets.eu


Mike-on-Tour
Active Member
Active Member
Posts: 5
Joined: 13. May 2019 21:03

Re: Portal on phpBB 3.3

Post by Mike-on-Tour » 12. January 2020 13:30

There are some more lines with 'continue;': 236, 241, 336, 346, 384, 529, 536 and 600). I advise to use Ctrl-H to find and replace them all.


juanpa
Active Member
Active Member
Posts: 4
Joined: 14. January 2020 19:52

Re: Portal on phpBB 3.3

Post by juanpa » 14. January 2020 19:54

Hello,

There are also bugs on News and Last Bot modules.

For now I had to desactivate them.

User avatar

Kirk
Portal Professional
Portal Professional
Posts: 1642
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: Portal on phpBB 3.3

Post by Kirk » 14. January 2020 20:05

What kind of error is shown?


juanpa
Active Member
Active Member
Posts: 4
Joined: 14. January 2020 19:52

Re: Portal on phpBB 3.3

Post by juanpa » 14. January 2020 20:42

When navigate with module Last message activated to:

Code: Select all

forum/app.php/portal
I got a blank page with this error message:

Code: Select all

Fatal error: Uncaught Error: Call to undefined method board3\portal\portal\fetch_posts::add_lang() in /htdocs/mywebsite.com/forum/ext/board3/portal/modules/news.php:122 Stack trace: #0 /htdocs/mywebsite.com/forum/ext/board3/portal/controller/main.php(255): board3\portal\modules\news->get_template_center('26') #1 /htdocs/mywebsite.com/forum/ext/board3/portal/controller/main.php(183): board3\portal\controller\main->get_module_template(Array, Object(board3\portal\modules\news)) #2 /htdocs/mywebsite.com/forum/vendor/symfony/http-kernel/HttpKernel.php(151): board3\portal\controller\main->handle(Array) #3 /htdocs/mywebsite.com/forum/vendor/symfony/http-kernel/HttpKernel.php(68): Symfony\Component\HttpKernel\HttpKernel->handleRaw(Object(phpbb\symfony_request), 1) #4 /htdocs/mywebsite.com/forum/app.php(35): Symfony\Component\HttpKernel\HttpKernel->handle(Object(phpbb\symfony_request)) #5 {main} thrown in /htdocs/mywebsite.com/forum/ext/board3/portal/modules/news.php on line 122
I just notice that if I desactivate the news module I got an error with Last members module

Code: Select all

Fatal error: Uncaught Error: Call to a member function sql_query_limit() on string in /htdocs/mywebsite.com/forum/ext/board3/portal/modules/latest_members.php:82 Stack trace: #0 /htdocs/mywebsite.com/forum/ext/board3/portal/controller/main.php(250): board3\portal\modules\latest_members->get_template_side('8') #1 /htdocs/mywebsite.com/forum/ext/board3/portal/controller/main.php(183): board3\portal\controller\main->get_module_template(Array, Object(board3\portal\modules\latest_members)) #2 /htdocs/mywebsite.com/forum/vendor/symfony/http-kernel/HttpKernel.php(151): board3\portal\controller\main->handle(Array) #3 /htdocs/mywebsite.com/forum/vendor/symfony/http-kernel/HttpKernel.php(68): Symfony\Component\HttpKernel\HttpKernel->handleRaw(Object(phpbb\symfony_request), 1) #4 /htdocs/mywebsite.com/forum/app.php(35): Symfony\Component\HttpKernel\HttpKernel->handle(Object(phpbb\symfony_request)) #5 {main} thrown in /htdocs/mywebsite.com/forum/ext/board3/portal/modules/latest_members.php on line 82
If I desactivate Last members I can access to the portal. Now let's try with Last Bots

Now I got directly the error in ACP when I activate Last Bots module

Code: Select all

Fatal error: Uncaught Error: Call to a member function set() on string in /htdocs/mywebsite.com/forum/ext/board3/portal/modules/latest_bots.php:127 Stack trace: #0 /htdocs/mywebsite.com/forum/ext/board3/portal/acp/portal_module.php(488): board3\portal\modules\latest_bots->install(27) #1 /htdocs/mywebsite.com/forum/includes/functions_module.php(676): board3\portal\acp\portal_module->main('\\board3\\portal\\...', 'modules') #2 /htdocs/mywebsite.com/forum/adm/index.php(81): p_master->load_active() #3 {main} thrown in /htdocs/mywebsite.com/forum/ext/board3/portal/modules/latest_bots.php on line 127

User avatar

Kirk
Portal Professional
Portal Professional
Posts: 1642
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: Portal on phpBB 3.3

Post by Kirk » 14. January 2020 21:00

What PHP version are you using?


juanpa
Active Member
Active Member
Posts: 4
Joined: 14. January 2020 19:52

Re: Portal on phpBB 3.3

Post by juanpa » 15. January 2020 12:08

HI,

I am on 7.2 php version, I have would like to switch to 7.3 (recommanded by my web Host) but because of some incompatibilities with phpBB3 I switch to 7.2

My PHP version did not change since I update phpBB3, and the Board3 did no have errors before this update

Edit: Try to switch to php 7.3, same errors:

News module:

Code: Select all

Fatal error: Uncaught Error: Call to undefined method board3\portal\portal\fetch_posts::add_lang() in /htdocs/mywebsite.com/forum/ext/board3/portal/modules/news.php:122 Stack trace: #0 /htdocs/mywebsite.com/forum/ext/board3/portal/controller/main.php(255): board3\portal\modules\news->get_template_center('28') #1 /htdocs/mywebsite.com/forum/ext/board3/portal/controller/main.php(183): board3\portal\controller\main->get_module_template(Array, Object(board3\portal\modules\news)) #2 /htdocs/mywebsite.com/forum/vendor/symfony/http-kernel/HttpKernel.php(151): board3\portal\controller\main->handle(Array) #3 /htdocs/mywebsite.com/forum/vendor/symfony/http-kernel/HttpKernel.php(68): Symfony\Component\HttpKernel\HttpKernel->handleRaw(Object(phpbb\symfony_request), 1) #4 /htdocs/mywebsite.com/forum/app.php(35): Symfony\Component\HttpKernel\HttpKernel->handle(Object(phpbb\symfony_request)) #5 {main} thrown in /htdocs/mywebsite.com/forum/ext/board3/portal/modules/news.php on line 122
Line 122

Code: Select all

		$this->user->add_lang('viewforum');
EDIT 2:

I omit to tell that at the begining just after the phpBB update I got this error in ACP

Code: Select all

phpBB a rencontré une erreur lors de la construction du conteneur en raison d’une extension installée. Pour cette raison, toutes les extensions ont été temporairement désactivées. Elles seront automatiquement réactivées dès que l’erreur de conteneur sera résolue. Pour cela, commencez par purger le cache de votre forum. Si cette erreur persiste, veuillez visiter le forum de support phpBB.com (en anglais) ou le forum de support phpBB-fr.com (en français).


Exception : The file "/htdocs/mywebsite.com/forum/ext/board3/portal/config/services.yml" does not contain valid YAML: The reserved indicator "@" cannot start a plain scalar; you need to quote the scalar at line 12 (near "- @board3.portal.columns").

#0 /htdocs/mywebsite.com/forum/vendor/symfony/dependency-injection/Loader/YamlFileLoader.php(117): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->loadFile('/htdocs/team-bo...')
#1 /htdocs/mywebsite.com/forum/phpbb/extension/di/extension_base.php(99): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->load('services.yml')
#2 /htdocs/mywebsite.com/forum/phpbb/extension/di/extension_base.php(63): phpbb\extension\di\extension_base->load_services(Object(Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationContainerBuilder))
#3 /htdocs/mywebsite.com/forum/vendor/symfony/dependency-injection/Compiler/MergeExtensionConfigurationPass.php(71): phpbb\extension\di\extension_base->load(Array, Object(Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationContainerBuilder))
#4 /htdocs/mywebsite.com/forum/vendor/symfony/http-kernel/DependencyInjection/MergeExtensionConfigurationPass.php(39): Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#5 /htdocs/mywebsite.com/forum/vendor/symfony/dependency-injection/Compiler/Compiler.php(140): Symfony\Component\HttpKernel\DependencyInjection\MergeExtensionConfigurationPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#6 /htdocs/mywebsite.com/forum/vendor/symfony/dependency-injection/ContainerBuilder.php(789): Symfony\Component\DependencyInjection\Compiler\Compiler->compile(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#7 /htdocs/mywebsite.com/forum/phpbb/di/container_builder.php(203): Symfony\Component\DependencyInjection\ContainerBuilder->compile()
#8 /htdocs/mywebsite.com/forum/common.php(115): phpbb\di\container_builder->get_container()
#9 /htdocs/mywebsite.com/forum/adm/index.php(23): require('/htdocs/team-bo...')
#10 {main}
I fix it by removing the @ like specified in the error message.


juanpa
Active Member
Active Member
Posts: 4
Joined: 14. January 2020 19:52

Re: Portal on phpBB 3.3

Post by juanpa » Yesterday 14:40

Ok, today I decided to deactivate the extension, remove the data and réactive the Board3 portal.

I got this error :

Code: Select all

Fatal error: Uncaught TypeError: Argument 1 passed to board3\portal\event\listener::__construct() must be an instance of board3\portal\controller\main, string given in /htdocs/mywebsite.com/forum/ext/board3/portal/event/listener.php:52 Stack trace: #0 [internal function]: board3\portal\event\listener->__construct('board3.portal.m...', 'auth', 'config', 'controller.help...', 'path_helper', 'template', 'user', 'php') #1 /htdocs/mywebsite.com/forum/vendor/symfony/dependency-injection/ContainerBuilder.php(1176): ReflectionClass->newInstanceArgs(Array) #2 /htdocs/mywebsite.com/forum/vendor/symfony/dependency-injection/ContainerBuilder.php(634): Symfony\Component\DependencyInjection\ContainerBuilder->createService(Object(Symfony\Component\DependencyInjection\Definition), Array, false, 'board3.portal.l...') #3 /htdocs/mywebsite.com/forum/vendor/symfony/dependency-injection/ContainerBuilder.php(1281): Symfony\Component\DependencyInjection\ContainerBuilder->doGet('board3.portal.l...', 1, Array, false) #4 /htdocs/mywebsite.com/forum/ven in /htdocs/mywebsite.com/forum/ext/board3/portal/event/listener.php on line 52

Return to “Board3 Portal 2.1.x - English Support”