AJAX-FEHLER No route found for "POST /ucp.php"

Aktuelle Version: 2.1.0
Veröffentlicht: 26.10.2015
Forum rules
Vor dem erstellen neuer Supportanfragen bitte zuerst in die board3 Portal FAQ schauen und die Suche benutzen!
Viele Fragen sind bereits schon gestellt und beantwortet worden.
Bitte auch unsere Forumsregeln lesen und beachten!
User avatar
Contergantreff
Topic author
Active Member
Active Member
Posts: 38
Joined: 13. January 2017 11:14
phpBB.de User: Contergantreff
phpBB.com User: Contergantreff

AJAX-FEHLER No route found for "POST /ucp.php"

Post by Contergantreff » 22. March 2017 10:39

Ich verzweifle gerade etwas, mit dieser Fehlermeldung. Zwar taucht die auf wenn ich unten im Bord auf “Alle Cookies des Boards löschen“ klicke.
Auf der Forumsseite selber taucht das Problem nicht auf. Ich habe derzeit bis auf dem Portal keine weiteren Module aktiviert.

Das Problem fing an mit der Erweiterung Ajax Shoutkebox und dem dazugehörigen Modul für das Portal. Diese Erweiterung habe ich mittlerweile entfernt aber die Fehlermeldung scheint immer noch damit zusammen zu hängen? Die Arbeitsdaten habe ich korrekt gelöscht und das Modul dann auch vom Webspace genommen.

Ich habe auch schon das Portal deaktiviert vom Webspace genommen, ein aktuelles hier aus dem Portal heruntergeladen und dieses neu eingerichtet.
Der Fehler bleibt bestehen.

Wo kann ich jetzt noch nach dem Fehler suchen?
MfG

Frank

User avatar
Kirk
Portal Professional
Portal Professional
Posts: 1496
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: AJAX-FEHLER No route found for "POST /ucp.php"

Post by Kirk » 22. March 2017 12:33

Der Link zum Portal ist bestimmt so : app.php/portal
Geh mal im ACP auf Server und Domain und klicke bei Umschreiben von URLs aktivieren auf ja, dann müsste der Fehler weg sein.

User avatar
Contergantreff
Topic author
Active Member
Active Member
Posts: 38
Joined: 13. January 2017 11:14
phpBB.de User: Contergantreff
phpBB.com User: Contergantreff

Re: AJAX-FEHLER No route found for "POST /ucp.php"

Post by Contergantreff » 22. March 2017 17:50

Kirk wrote:
22. March 2017 12:33
Der Link zum Portal ist bestimmt so : app.php/portal
Geh mal im ACP auf Server und Domain und klicke bei Umschreiben von URLs aktivieren auf ja, dann müsste der Fehler weg sein.
Wenn ich das ändere ist das Portal nicht mehr erreichbar (Forum geht weiterhin).
in der .htaccess steht folgendes müsste man dann da etwas ändern?

Code: Select all

DirectoryIndex app.php/portal index.php index.html index.htm
MfG

Frank

User avatar
Kirk
Portal Professional
Portal Professional
Posts: 1496
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: AJAX-FEHLER No route found for "POST /ucp.php"

Post by Kirk » 22. March 2017 18:26

Normalerweise sollte das Portal weiterhin erreichbar sein, frage doch mal bei deinem Hoster nach ob der Server die Umschreibung von URLs unterstützt.
Das Portal kann so domain.de/app.php/portal oder so aufgerufen werden domain.de/portal
Der Eintrag in die .htaccess solltest du so lassen wenn du das Portal als Startseite verwenden möchtest.

User avatar
Contergantreff
Topic author
Active Member
Active Member
Posts: 38
Joined: 13. January 2017 11:14
phpBB.de User: Contergantreff
phpBB.com User: Contergantreff

Re: AJAX-FEHLER No route found for "POST /ucp.php"

Post by Contergantreff » 22. March 2017 19:41

Kirk wrote:
22. March 2017 18:26
domain.de/portal
Dieser Link funktioniert dann nicht mehr.
Ich habe die Einstellungen mal mit meinem alten Portal verglichen, Dort ist es auch nicht aktiviert.
Wenn es ein eher unwichtige Funkion ist, würde ich den Link unten im Portal raus nehmen. Oder sind noch andere Probleme dadurch zu erwarten, das dasCookie löschen nicht sauber funktioniert?
MfG

Frank

User avatar
Kirk
Portal Professional
Portal Professional
Posts: 1496
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: AJAX-FEHLER No route found for "POST /ucp.php"

Post by Kirk » 22. March 2017 21:06

Ich denke das es evtl. an diesen Änderungen liegt.
Dieser Link "Alle Cookies des Boards löschen" ist in der overall_footer.html deines Styles definiert, diese Datei wird im Portal nur per INCLUDE Anweisung in das Portal eingebunden.

User avatar
Contergantreff
Topic author
Active Member
Active Member
Posts: 38
Joined: 13. January 2017 11:14
phpBB.de User: Contergantreff
phpBB.com User: Contergantreff

Re: AJAX-FEHLER No route found for "POST /ucp.php"

Post by Contergantreff » 22. March 2017 21:56

Contergantreff wrote:
9. February 2017 11:55
Kirk wrote:
8. February 2017 21:26
Was das ausloggen agenht, so gibt dafür eine Extension, funktioniert unter 3.2.0 ohne Probleme.
Danke Kkrk,
die Erweiterung läuft auch unter 3.1 mit Portal sauber.
Diese Erweiterung ist derzeit auch deaktiviert und.und nur die .htaccess geändert. Ich habe meinen Provider angeschrieben und warte da erstmal ab.

Antwort vom Provider:
vielen Dank für Ihre Anfrage.

Serverseitig steht die Möglichkeit der URL Umschreibung zur Verfügung. Eine manuelle Aktivierung durch uns ist nicht notwendig.

Meist wird das Umschreiben per .htaccess realisiert.

Bei weiteren Fragen stehen wir Ihnen gern zur Verfügung.

ich schaue mir deinen Link morgen nochmal in ruhe an....
Last edited by Contergantreff on 22. March 2017 22:05, edited 1 time in total.
MfG

Frank

User avatar
Kirk
Portal Professional
Portal Professional
Posts: 1496
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: AJAX-FEHLER No route found for "POST /ucp.php"

Post by Kirk » 23. March 2017 02:04

Ich kann diese Verhalten nicht nachvollziehen, bekommst irgendwelche Fehlermeldungen?
Dieser von dir angesprochene AJAX-FEHLER bekommt man in anderen Extensionen ebenso (Wenn in der URL app.php enthalten ist).

User avatar
Contergantreff
Topic author
Active Member
Active Member
Posts: 38
Joined: 13. January 2017 11:14
phpBB.de User: Contergantreff
phpBB.com User: Contergantreff

Re: AJAX-FEHLER No route found for "POST /ucp.php"

Post by Contergantreff » 23. March 2017 09:38

Guten morgen, die von Dir angesprochenen Änderungen (
Kirk wrote:
22. March 2017 21:06
Ich denke das es evtl. an diesen Änderungen liegt.
habe ichJetzt gerade nicht drin, weil ich ja ein neues Portal von hier heruntergeladen habe.
Die Installation liegt in einem Unterordner drin, daran dürfte es aber auch nicht liegen da die Pfade angepasst sind.

Image Image

Oder siehst du da irgendwo einen Fehler?.

Ins Haupt Verzeichnis rein kann ich die Installation nicht legen, weil dort mein aktuelles Portal mit Forum in der Version Forum 3.0.12 Portal Board3 Portal
1.0.6 Der Server konnte nicht erreicht werden

Bevor die neue Installation nicht sauber läuft kann ich auch noch nicht umsteigen.


Dieser Link geht nicht, wenn ich die Umstellung gemacht habe.
http://www.contergantreff.eu/contergantreff/portal

Image


Dieser Link http://www.contergantreff.eu/contergant ... php/portal geht, aber du kommst nicht weiter aufs Portal.
MfG

Frank

User avatar
Contergantreff
Topic author
Active Member
Active Member
Posts: 38
Joined: 13. January 2017 11:14
phpBB.de User: Contergantreff
phpBB.com User: Contergantreff

Re: AJAX-FEHLER No route found for "POST /ucp.php"

Post by Contergantreff » 27. March 2017 10:24

Problem hat sich erledigt, hatte knoten in der .htaccess
MfG

Frank

Return to “Board3 Portal 2.1.x - Deutscher Support”