Fehlermeldung: services.yml" does not contain valid YAML:

Aktuelle Version: 2.1.0
Veröffentlicht: 26.10.2015
Forum rules
Vor dem erstellen neuer Supportanfragen bitte zuerst in die board3 Portal FAQ schauen und die Suche benutzen!
Viele Fragen sind bereits schon gestellt und beantwortet worden.
Bitte auch unsere Forumsregeln lesen und beachten!

Topic author
Zausel
Active Member
Active Member
Posts: 29
Joined: 7. April 2016 21:19

Fehlermeldung: services.yml" does not contain valid YAML:

Post by Zausel » 16. January 2020 10:57

Moin,
nachdem ich von PhpBB3.2.8 die neuste PhpBB-Version 3.3 installiert habe erhalte ich diese Fehlermeldung:

Code: Select all

Beim Aufbau des Containers durch phpBB ist wegen einer installierten Erweiterung ein Fehler aufgetreten. 
Aus diesem Grund wurden alle Erweiterungen vorrübergehend deaktiviert. 
Bitte versuchen Sie das Problem zu beheben, in dem Sie den Cache des Boards leeren. 
Alle Erweiterungen werden automatisch wieder aktiviert, sobald der Container-Fehler behoben ist. 
Wenn das Problem dauerhaft auftritt, besuchen Sie bitte phpBB.com (englisch) für Support (deutschsprachiger Support auf phpBB.de).


Fehler: The file "/www/htdocs/xxxx/lisa.broschatt.de/ext/board3/portal/config/services.yml" does not contain valid YAML: The reserved indicator "@" cannot start a plain scalar; you need to quote the scalar at line 12 (near "- @board3.portal.columns").

#0 /www/htdocs/xxxx/lisa.broschatt.de/vendor/symfony/dependency-injection/Loader/YamlFileLoader.php(117): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->loadFile('/www/htdocs/w00...')
#1 /www/htdocs/xxxx/lisa.broschatt.de/phpbb/extension/di/extension_base.php(99): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->load('services.yml')
#2 /www/htdocs/xxxx/lisa.broschatt.de/phpbb/extension/di/extension_base.php(63): phpbb\extension\di\extension_base->load_services(Object(Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationContainerBuilder))
#3 /www/htdocs/xxxx/lisa.broschatt.de/vendor/symfony/dependency-injection/Compiler/MergeExtensionConfigurationPass.php(71): phpbb\extension\di\extension_base->load(Array, Object(Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationContainerBuilder))
#4 /www/htdocs/xxxx/lisa.broschatt.de/vendor/symfony/http-kernel/DependencyInjection/MergeExtensionConfigurationPass.php(39): Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#5 /www/htdocs/xxxx/lisa.broschatt.de/vendor/symfony/dependency-injection/Compiler/Compiler.php(140): Symfony\Component\HttpKernel\DependencyInjection\MergeExtensionConfigurationPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#6 /www/htdocs/xxxx/lisa.broschatt.de/vendor/symfony/dependency-injection/ContainerBuilder.php(789): Symfony\Component\DependencyInjection\Compiler\Compiler->compile(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#7 /www/htdocs/xxxx/lisa.broschatt.de/phpbb/di/container_builder.php(203): Symfony\Component\DependencyInjection\ContainerBuilder->compile()
#8 /www/htdocs/xxxx/lisa.broschatt.de/common.php(115): phpbb\di\container_builder->get_container()
#9 /www/htdocs/xxxx/lisa.broschatt.de/adm/index.php(23): require('/www/htdocs/w00...')
#10 {main} 
Dann habe ich die Back Ups wieder installiert und versucht von PhpBB 3.2.8 erst auf 3.2.9 zu installieren. Wenn ich das Portal aktiviere erfolgt auch die o.g. Fehlermeldung.

Dann versucht die PHP Version von 7.1.24 auf 7.2. umgestellt. Fehler bleibt, das Forum ist erst wieder aufrufbar wenn das Portal deaktiviert wird. Schade!


Topic author
Zausel
Active Member
Active Member
Posts: 29
Joined: 7. April 2016 21:19

Re: Fehlermeldung: services.yml" does not contain valid YAML:

Post by Zausel » 16. January 2020 11:15

Sehe gerade das hier im EN-Support jemand die gleiche Fehlermeldung hat: https://www.board3.de/viewtopic.php?f=71&t=11666#p38488 - Wenn dort die Lösung käme kann ich sie nicht lesen..... mein Englisch ist sehr begrenzt. :oops:

User avatar

Kirk
Portal Professional
Portal Professional
Posts: 1650
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: Fehlermeldung: services.yml" does not contain valid YAML:

Post by Kirk » 16. January 2020 13:25



Topic author
Zausel
Active Member
Active Member
Posts: 29
Joined: 7. April 2016 21:19

Re: Fehlermeldung: services.yml" does not contain valid YAML:

Post by Zausel » 16. January 2020 17:02

Oh danke für den Hinweis, ich habe die Änderungen übernommen.

Nun ist Portal nicht mehr zu sehen und im ACP steht " es wurden keine Module gefunden". :oops:
Liegt es an der PHP Version 7.2.24

Nachtrag: ich kann auch keine Module hinzufügen. Es erscheint auch keine Fehlermeldung.

Nachtrag 2: Portal deaktiviert und wieder aktiviert dann habe ich diese Meldung:
Information
Konfiguration erfolgreich aktualisiert.

Während dem Prüfen des Modul Bildes sind ein oder mehrere Fehler aufgetreten:
Die angegebene Datei konnte nicht gefunden werden: styles/all/theme/images/portal/


Cherrystone
Active Member
Active Member
Posts: 10
Joined: 13. January 2020 18:22

Re: Fehlermeldung: services.yml" does not contain valid YAML:

Post by Cherrystone » 16. January 2020 19:21

Hallo Zausel, wie hast du es geschafft dass das Portal bei dir überhaupt läuft? Habe auch das aktuellsten PHPbb3 installiert.. Allerdings sehe ich kein Portal bei mir..


Topic author
Zausel
Active Member
Active Member
Posts: 29
Joined: 7. April 2016 21:19

Re: Fehlermeldung: services.yml" does not contain valid YAML:

Post by Zausel » 16. January 2020 19:47

Hallo Cherrystone
das Portal läuft bei mir NICHT.
Ich habe diese Änderungen übernommen:

mit den Ergebnis das zwar keine Fehlermeldungen vorhanden, aber das Portal nicht mehr sichtbar ist. Im ACP / Portal/Module sind sämtliche Module verschwunden und ich kann keine anlegen.
Image

User avatar

Kirk
Portal Professional
Portal Professional
Posts: 1650
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: Fehlermeldung: services.yml" does not contain valid YAML:

Post by Kirk » 16. January 2020 20:45

Ich werde am Wochenende die Portal Version die in meinem TB unter 3.3 ohne ersichtliche Probleme läuft, nochmals ausgiebig testen und ggf. die zum Download anbieten.


Cherrystone
Active Member
Active Member
Posts: 10
Joined: 13. January 2020 18:22

Re: Fehlermeldung: services.yml" does not contain valid YAML:

Post by Cherrystone » 16. January 2020 20:53

Und genau da bin ich auch! Alles installiert, Änderungen vorgenommen.. Aber keine Ansicht.. Und keine Module.. Keine Fehler.. Ist echt schade!


Topic author
Zausel
Active Member
Active Member
Posts: 29
Joined: 7. April 2016 21:19

Re: Fehlermeldung: services.yml" does not contain valid YAML:

Post by Zausel » 16. January 2020 22:09

Ein bischen Geduld sollte man schon haben, denn das Portal wird ohne jegliche Kosten angeboten. ;)

Also warte ich noch ab. Vielleicht ergibt sich übers WE dann eine Lösung.

Übrigens habe ich noch eine Exts, welche genau die selbe Fehlermeldung ausgibt, Problem scheinen die yml-Dateien zu sein.

User avatar

Kirk
Portal Professional
Portal Professional
Posts: 1650
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: Fehlermeldung: services.yml" does not contain valid YAML:

Post by Kirk » 17. January 2020 16:28

Ich habe meine Portal Version nochmal getestet, mit dieser konnte ich keine Probleme feststellen.
Ihr könnt euch diese auf meiner Seite downloaden.
Getestet mit phpBB 3.3.0 sowie php 7.3.7


Mike-on-Tour
Active Member
Active Member
Posts: 6
Joined: 13. May 2019 21:03

Re: Fehlermeldung: services.yml" does not contain valid YAML:

Post by Mike-on-Tour » 17. January 2020 18:14

Zausel wrote:
16. January 2020 22:09
Übrigens habe ich noch eine Exts, welche genau die selbe Fehlermeldung ausgibt, Problem scheinen die yml-Dateien zu sein.
Es sind die yml-Dateien. Unter phpBB 3.1.x wurden die Extensions eingeführt, deren Konfiguration erfolgt über yml-Dateien, in der modules.yml werden Module und über services.yml die Klassen eingebunden, die die eigentliche Arbeit übernehmen. Zunächst wurde die Schreibweise ohne Hochkommata für die Einträge definiert. Mit Einführung von phpBB 3.2.x wurden Hochkommata Pflicht, die Schreibweise ohne wurde aber noch akzeptiert. phpBB 3.3.0 tut das nicht mehr, alle yml-Dateien ohne Hochkommata verursachen Fehler beim Aktivieren der jeweiligen Extension; deren Autoren müssten also eine neue Version bereit stellen. Kann man aber notfalls mit einem Editor (Notepad++, NICHT Editoren von Windows) selbst machen, dabei darau achten, dass für Einzüge KEINE Tabs sondern NUR Leerzeichen verwendet werden dürfen; wer das nicht beachtet, bekommt auch eine YAML-Fehlermeldung beim Aktivieren.


Topic author
Zausel
Active Member
Active Member
Posts: 29
Joined: 7. April 2016 21:19

Re: Fehlermeldung: services.yml" does not contain valid YAML:

Post by Zausel » 17. January 2020 18:36

Vielen Dank für Deine Mühe Kirk. Ich werde auf einer meiner Testforen die neue Version installieren. :)

Danke auch an Mike für die ausführliche Erklärung. Hatte mir schon gedacht das es an den .yml-Dateien liegen muss. Ich arbeite schon lange mit Notepad++. Leider kann ich außer bischen html kein weiteren Programmiersprachen, aber ich kann lesen. Dauert alles bischen länger aber letztendlich komme ich auch so zum Ziel. ;)

Edit: läuft ohne Probleme | eigene Module| PHP 7.2.24 | MySQL(i) 5.6.44-nmm1-log :mrgreen:


Mike-on-Tour
Active Member
Active Member
Posts: 6
Joined: 13. May 2019 21:03

Re: Fehlermeldung: services.yml" does not contain valid YAML:

Post by Mike-on-Tour » 18. January 2020 21:46

Kirk wrote:
17. January 2020 16:28
Ich habe meine Portal Version nochmal getestet, mit dieser konnte ich keine Probleme feststellen.
Ihr könnt euch diese auf meiner Seite downloaden.
Getestet mit phpBB 3.3.0 sowie php 7.3.7
Läuft!! Prima Arbeit und schnell, ganz großes "Danke schön"


mad_flyer_one
Active Member
Active Member
Posts: 1
Joined: 22. January 2020 10:38

Re: Fehlermeldung: services.yml" does not contain valid YAML:

Post by mad_flyer_one » 22. January 2020 10:59

Kirk wrote:
17. January 2020 16:28
Ich habe meine Portal Version nochmal getestet, mit dieser konnte ich keine Probleme feststellen.
Ihr könnt euch diese auf meiner Seite downloaden.
Getestet mit phpBB 3.3.0 sowie php 7.3.7
Moin Allerseits,
ich hab auf meiner Test-Seite (http://www.mad.1adaszockerparadies.de/) den selben Fehler. Aktuell hab ich phpBB 3.3.0 und php 7.3.13
Die beiden services.yml Datei Versionen hab ich hochgeladen, leider ohne Erfolg. Bei der phpBB Version handelt es sich um eine reine Installation ohne Anpassungen. Wahrscheinlich hab ich irgendwo einen kleinen Fehler, nur weiss ich nicht wo. Vielleicht habt Ihr noch eine Idee oder ggf. eine Version, welche mit den oben genannten php Versionen funktioniert.

Grüße
mad

User avatar

Kirk
Portal Professional
Portal Professional
Posts: 1650
Joined: 27. July 2010 18:02
phpBB.de User: Kirk

Re: Fehlermeldung: services.yml" does not contain valid YAML:

Post by Kirk » 22. January 2020 16:59

Nimm diese angepasste Version von mir, Link in meiner Signatur.

Return to “Board3 Portal 2.1.x - Deutscher Support”